dogecoind won’t read conf

I’m having issues starting dogecoind after compiling in ubuntu 12.04 x64 running in VirtualBox on win 7 ultimate x64

here’s what i’ve tried from inside dogecoin/src after make -f makefile.unix:

sudo su
./dogecoind -server -listen -daemon -rpcuser=dogerpc -rpcpassword=dogerpcpw -rpctimeout=30 -rpcport=8334 -rpcallowip=192.168.1.* -rpcallowip=127.0.0.1 -testnet

and i get:

Error: To use the "-server" option, you must set a secure rpcpassword in the configuration file:
/root/.dogecoin/dogecoin.conf

so i do:

cd ~/.dogecoin
emacs dogecoin.conf

i save the following parameters:

rpcuser=dogerpc
rpcpassword=dogerpcpw
rpcport=8334
rpcallowip=192.168.1.*
rpcallowip=127.0.0.1
server=1
daemon=1
listen=1
testnet=1

i even chmod 777 dogecoin.conf to be sure everyone on God’s green earth could access it so that wouldn’t be a problem, but still the same error when trying to start up dogecoind

would much appreciate any help/tips!

Continue reading dogecoind won’t read conf

Leave a Comment